Theme Options Blank in 3.9
  • Hi,

    Wordpress Version: 3.9
    Ripple Theme: 1.3.3
    PixelThrone Plugin: 1.3.3
    Environment: Online

    Since updating wordpress to 3.9 I can no longer edit anything under PixelThrone Theme Options in the admin area. Clicking on the sidebar selections eg General Settings / Styling Options etc just return a blank screen like this: http://imgur.com/8Aqiu47

    Have tried this on Chrome, Firefox, Safari with the same results on each browser. Have also tried on private browsing in order to ensure browser caches are cleared.

    As far as dev tools or logs can tell me, there is an issue with jQuery where the Console tells me "Uncaught SyntaxError: Unexpected token u" in chrome: http://i.imgur.com/dox4B96.png

    For the sake of this image and for narrowing down where the error was triggering I beautified the jQuery.js used.

    Cheers,

    Rikard
  • UPDATE: I have managed to temporarily fix this by reverting to jQuery 1.10 (WP 3.9 uses 1.11). This is not 100% ideal as I´m unsure of the ramifications it might have elsewhere, but it will at least allow me to alter Theme settings.
  • you can send me your wp login so I take a look?
    It is very strange that situation. Liked to see which plugins you have more, and if is someone that cause this problem.

    Sends by private message.
  • I have exactly the same issue. Any fix yet?
  • Oh, and I also get this error when i hit save in the theme options panel:
    Cannot open file: /Library/WebServer/Documents/wonderlab_co_nz/wp-content/themes/ripple/less/site-options.less
  • Hi, Duffdaddy
    To fix this you must give some files permissions to written.

    Check out this video to learn how.

  • Cool, thanks, will give it a go in the A.M. when I'm back at work, but pretty sure all permissions were 755.
    Will this fix the control panel issue too?
  • The cpanel is something else.
    On some servers the php has this option "allow_url_fopen" turned off .
    for the theme works is needed that is turn ON
  • okay, will check what it's set too.
  • If it does not work, come back.
  • Ok, it's on and I've corrected the permissions and still no control panel.
    What else to try?
    I'm getting these kind of errors in the console when I refresh the page with the cpanel in it.:

    [Error] SyntaxError: JSON Parse error: Unexpected identifier "undefined"
    parseJSON (load-scripts.php, line 4)
    parseJSON (load-scripts.php, line 8)
    b (redux.min.js, line 4)
    (anonymous function) (redux.min.js, line 4)
    each (load-scripts.php, line 2)
    each (load-scripts.php, line 2)
    (anonymous function) (redux.min.js, line 4)
    j (load-scripts.php, line 2)
    fireWith (load-scripts.php, line 2)
    ready (load-scripts.php, line 2)
    K (load-scripts.php, line 2)
  • Hi,
    It is a strange situation.
    Send me your login wordpress and FTP login for I to take a look.
    Sends by PM.
  • Have PM'd you my login.
  • Any luck checking it out?
  • Hi,
    I have sent you a private message.

    Here:
    Can you send me your FTP login.
    I whant toinstall a plugin and enable erro alerts.
  • Bugger. Sorry. Will have to sort Monday.